Рыбы ЯНАО

Изучаем родной язык. Тема "Рыбы"

1. Переведите название рыбы на русский язык:

Карась

Окунь

Ёрш

Лещ

2. Переведите на русский язык название одной из самых крупных рыб Ямала:

Муксун

Осетр

Нельма

Щука

3. Определите, какая рыба изображена на картинке, переведите ее название на хантыйский язык:

4. Переведите название рыбы на русский язык и выберите рисунок, на котором она изображена:

5. Переведите название рыбы на русский язык:

елец - чебак

пыжбян

сырок

муксун

6. Какая рыба изображена на гербе Шурышкарского района? Переведите название рыбы на хантыйский язык:

7. Переведите название рыбы на русский язык:

Щука

Язь

Муксун

Карась


  TESTMAKER VVZ 1.2

  Эта версия конструктора тестов выполняет две основные функции.

  Во-первых, она позволяет вводить исходные данные для тестов и сохранять их для возможной
дальнейшей правки. Введенные вопросы можно редактировать, добавлять варианты ответов и т.д.

  Во-вторых, при сохранении теста в формате HTML формируется интерактивная Web-страница, которая
может быть размещена на сервере либо использована локально.

  Интерактивность теста обеспечивается процедурами на языке JavaScript.
__________________________________________________________________________________________

  Добавления по сравнению с предыдущими версиями TestMaker 1.x:
  - возможность подключения изображений и звуковых файлов, иллюстрирующих вопросы и варианты
    ответов. Изображения должны быть сохранены в формате GIF либо JPEG, звуковые файлы - в
    формате WAV, MIDI либо MP3.
  - задание параметров шрифта при сохранении в формате HTML.
  - задание структуры теста при сохранении в формате HTML (не задействовано в пробной версии).
  - задание ограничений по времени на каждый вопрос либо на выполнения теста в целом
    (не задействовано в пробной версии).

  Изменения по сравнению с предыдущими версиями TestMaker VVZ 1.0 - 1.1:
  - HTML-вариант теста формируется без использования фреймов.
  - вместо многочисленных кнопок, подтверждающих ответ на каждый из вопросов, осталась одна,
    нажатие на которую выводит результаты всего теста. После вывода результатов вопросы
    помечаются символическими значками в зависимости от того, правильным ли был ответ.
  - исключен параметр, ограничивающий количество попыток ответа на каждый вопрос. Номер попытки
    выводится в поле результатов теста.

__________________________________________________________________________________________

  Исходные данные представляют собой:
  - набор вопросов;
  - варианты ответов, соответствующих каждому вопросу;  правильные варианты ответов
    (один либо несколько) должны быть помечены;
  - количество баллов, начисляемых за правильный ответ;
  - параметры, отвечающие за внешнее оформление Web-страницы (текст заголовков, цвета текста и
    фона, параметры шрифта, графика). Цвета либо вводятся согласно принятой в HTML
    шестнадцатеричной форме, либо выбираются в палитре.
__________________________________________________________________________________________

  Если Вы собираетесь в дальнейшем дополнять и редактировать тестовый материал, то, введя данные,
не забудьте сохранить их в формате TestMaker.

  При сохранении в формате TestMaker формируется один файл с расширением TST и два
файла с расширением TS :
  - [имя файла].tst
  - [имя файла]_quest.ts
  - [имя файла]_ans.ts
  Открывая ранее созданный тест для правки и доработки, надо указать [имя файла] .

  При сохранении в формате HTML формируются файлы:
  - [имя файла].js , содержащий код JavaScript;
  - [имя файла].css, содержащий стилевые описания CSS;
  и файлы HTML-документов:
  - [имя файла].html   - стартовая Web-страница теста
  - [имя файла]1.htm  ...  [имя файла]N.htm,
    где N - количество HTML-документов с вопросами ( N=1, если все вопросы
    выводятся в одном документе ).

  При наличии изображений и звуковых файлов, иллюстрирующих вопросы и варианты ответов,
создаются папки для их хранения.
  Файлы изображений копируются в папку [имя файла]_Img.
  Звуковые файлы копируются в папку [имя файла]_Sound.
__________________________________________________________________________________________

   NB! Ориентируясь исключительно на СВОИ ОТРИЦАТЕЛЬНЫЕ ЭМОЦИИ по поводу сообщений о
подтверждении перезаписи существующего файла, я подобных сообщений не выдаю. Учтите, что
существующий вариант теста БУДЕТ ПЕРЕЗАПИСАН в процессе сохранения БЕЗ КАКИХ БЫ ТО НИ
БЫЛО СООБЩЕНИЙ. Будьте внимательны!
__________________________________________________________________________________________

  NB!
  Количество символов (включая пробелы) в вопросе и варианте ответа ограничено 255.
__________________________________________________________________________________________

  NB!
  Давая имя файлу теста и файлам изображений, следуйте правилам адресации web-ресурсов. Не
используйте символы кириллицы, пробелы, кавычки и другие спец. символы. Используйте латинские
буквы и цифры.
__________________________________________________________________________________________

  NB!
  О задании параметров шрифта при сохранении в формате HTML.
  Помимо стандартных наборов гарнитур, традиционно задаваемых в описаниях каскадных таблиц
стилей ( например, группа рубленых гарнитур "Verdana,Helvetica,Arial,sans-serif" ), предусмотрен
выбор иного шрифта из множества установленных на компьютере пользователя TestMaker.
  Надо помнить, что при публикации теста в Интернете большинство "экзотических" шрифтов будет
отсутствавать на клиентских компьютерах потенциальных пользователей. В том случае, когда
конкретный шрифт с нестандартными символами ДЕЙСТВИТЕЛЬНО НЕОБХОДИМ для правильного
отображения тестового материала, следует в HTML-документе, предшествующем переходу к тесту,
предложить пользователю загрузить на свой компьютер и установить требуемый шрифт.
  Возможность выбора особого шрифта добавлена в TestMaker в связи с его использованием при
разработке дистанционного учебника на кафедре фонетики филологического факультета СПбГУ.
Это один из примеров исходного материала, когда без специально разработанного шрифта,
включающего символы, принципиально отсутствующие в стандартных шрифтах (символы транскрипции),
правильное отображение вопросов и вариантов ответов невозможно.
  Учтите, что "доморощенные" шрифты могут некорректно отображаться браузерами.
__________________________________________________________________________________________


Программа конструирования тестов "TestMaker"

Тобольский государственный педагогический институт им. ДиИ. Менделеева

Филиал в г. Салехарде

Центр информационно-образовательных технологий

© TGPI Salekhard Filial CIOT 2005


Программа конструирования тестов "TestMaker"

Программа конструирования тестов

“TESTMAKER”

1. Запуск и интерфейс программы

  • Вкладка ОСНОВНЫЕ (Рис.2)

  • Вкладка «ЦВЕТА И ОФОРМЛЕНИЕ» (Рис.3)

  • Вкладка «ШРИФТ» (Рис. 4)

  • Вкладка «СТРУКТУРА» (Рис. 5)

2. Практическая работа с программой.

2.1. Общие рекомендации по работе с программой

2.2. Технология создания теста

2.2.1. Запись вопроса

2.2.2. Запись ответов

2.2.3. Сохранение теста

2.2.4. Сохранение теста в формате HTML

Программа написана на основе языка JavaScript

Автор – Валентина Захаркина ( http://vvz.nw.ru; E-Mail : vvz@icape.nw.ru)

Отличия от предыдущих версий программы и некоторые технические данные, которые могут оказаться полезными, можно прочитать в HELP`e программы (значок «?»).

1. Запуск и интерфейс программы

Запуск программы производится из корневой паки программы файлом testmake.exe.

Перед вами откроется главное окно программы:

Рис. 1. Главное окно программы

Как видно на рисунке, интерфейс программы обычного и привычного типа.

Вверху находится строка МЕНЮ, содержащая всего лишь три раздела: ТЕКСТ, ПАРАМЕТРЫ и ?.

Раздел ФАЙЛ содержит 5 пунктов и соответствующие им «горячие клавиши»:

- Создать ( Ctrl + N);

- Открыть (Ctrl + O );

- Сохранить (Ctrl + S );

- Сохранить в формате HTML ( Ctrl + H);

- Выход.

При входе в раздел ПАРАМЕТРЫ открывается многоуровневое окно:

Рис. 2. Окно раздела «Параметры текста»

Окно содержит 4 вкладки:

Основные (Рис. 2);

Цветаи оформление (Рис. 3);

Шрифт (Рис.4);

Структура (Рис. 5);

Другие (Рис.6).

Ознакомимся с этими вкладками подробнее.

Вкладка ОСНОВНЫЕ (Рис.2)

В поле «Заголовок теста» вы должны ввести название вашего будущего теста. Название не должно быть слишком длинным (максимум 2-3 слова); может быть введено заглавными буквами – так оно и отобразится в браузере.

В поле «Текст в строке заголовка браузера» вводится поясняющий текст, который будет отображен в заголовке браузера и в теге <TITLE>…</TITLE> вашего будущего HTML-файла, содержащего собственно текст.

Если вы желаете чтобы вводимые вами вопросы (с ответами) в тесте автоматически были пронумерованы, то поставьте «галочку» в окошке «Нумерация вопросов».

Очень наглядно выглядит тест, если после ответа на вопросы и вывода результатов, возле вопросов теста появлялся синий «крестик» (неправильные ответы) или красная «галочка» (правильные ответы). Если вы желаете, чтобы ваш будущий тест содержал эти элементы – поставьте «галочку» в окошке «Маркировка правильных и неправильных ответов по результатам теста».

Здесь же вы можете установить количество попыток ответа на вопросы теста, после каждой попытки будет появляться новое сообщение с результатами новой попытки и с результатами прошлой. При превышении числа попыток будет выведено соответствующее сообщение и тест будет закончен.

Вкладка «ЦВЕТА И ОФОРМЛЕНИЕ» (Рис.3)

Рис. 3. Вкладка «Цвета и оформление»

Содержание вкладки понятно из рисунка.

Выбор соответствующих цветов можно сделать, если нажать мышкой на соответствующее окошко, появится небольшая палитра, где вы можете выбрать нужный цвет для данного элемента:

Рис. 3а. Палитра цветов элементов

Если вы хотите, чтобы фоном вашей будущей HTML-страницы служил рисунок, нажмите кнопку «Обзор» и укажите нужный графический файл (формат *.GIF или *.JPG; другие формату желательно не использовать, чтобы не увеличивать неоправданно готовый тест)).

Вы можете выбрать изображение-логотип для вашего теста таким же образом, как и выбирается фоновое изображение (то есть нажать кнопку «Обзор» и т.д.). По умолчанию в ваш тест будет установлен стандартный логотип, например, такой

или такой:

Если вы хотите создать свой логотип, вы должны помнить, что он должен быть в формате *.GIF или *.JPG, размеры изображения –156 х 53 пикселя при разрешении 72 пикселя на дюйм (72 dpi), это соответствует геометрическим размерам 5,5 х 1,87 см.

Впрочем, вы всегда можете изменить логотип или вообще обойтись без него, заменив логотип шрифтовой надписью, используя средства HTML-редактирования.

Вкладка «ШРИФТ» (Рис. 4)

Рис. 4. Вкладка «ШРИФТ»

В окошке «Шрифт» выбирается семейство шрифтов, которые будут использованы при создании вашего теста. В окошках «Основной текст» и «Заголовок» выбирается размер шрифта для соответствующих элементов будущего теста. Можно порекомендовать оставить размер основного текста в 9 пунктов, а вот для заголовка использовать 16 пунктов. Впрочем, опять-таки, при желании можно отредактировать шрифты теста с помощью HTML-редактора в дальнейшем.

Вкладка «СТРУКТУРА» (Рис. 5)

Рис. 5. Вкладка «Структура»

Эта вкладка работает только в зарегистрированной версии программы. В пробной версии она бездействует. Зарегистрироваться и получить возможность работы с этой вкладкой, можно на сайте автора (http://vvz.nw.ru) или связавшись с автором лично (vvz@icape.nw.ru).

Это же относится и к вкладке «ДРУГИЕ».

2. Практическая работа с программой.

2.1. Общие рекомендации по работе с программой

Работу над тестом следует начать с его «черновика», выполняемого в WORDе. Составляется список вопросов и вариантов ответов к ним, причем помечается правильный ответ. Это может выглядеть примерно таким образом:

Вопрос №1

Когда был создан первый компьютер?

1. В 19 веке

2. В начале ХХ века

3. В середине ХХ века

4. В конце ХХ века.

Вопрос № 2

. . . . .

И т.д.

Можно распечатать этот список вопросов и ответов, а затем поочередно вводить его в «Текстмейкер».

Предпочтительнее сохранить файл со списком вопросов, но не закрывать его, а «держать» его на экране параллельно с «Тестмейкером»: по мере работы над тестом, каждый вопрос копируется из вордовского файла в буфер (CTRL + C), а затем вставляется (CTRL + V) в соответствующее окошко программы.

2.2. Технология создания теста

2.2.1. Запись вопроса

Рис. 6. Запись вопросов

Перед созданием теста (то есть проекта), необходимо создать на своем компьютере папку с именем вашего теста; в ней программа разместит все файлы проекта, а также присоединенные файлы (графические и звуковые). Очень желательно назвать эту папку (и вообще все, что вы сохраняете в «Тестмейкере»!) латинскими («английскими») буквами, это исключит какие-либо неприятности с адресацией объектов в HTML , да и вообще код HTML и русский алфавит – вещи несовмесимые.

Вопрос записывается (или вставляется из буфера памяти) в окошко «Список вопросов». Здесь же вы можете ввести количество баллов, которым вы оцениваете правильный ответ на данный вопрос. Если у вас имеется картинка или звуковой файл, сопровождающий содержание вопроса, вы можете поместить их в тест, нажав кнопки «Картинка к вопросу» или (и) «Звук к вопросу». При этом откроется мини-браузер для поиска соответствующих файлов. Характерно, что эти файлы автоматически будут перенесены программой в папку, в которой содержится ваш проект.

2.2.2. Запись ответов

Рис.7. Запись ответов

Ответ записывается (или вставляется из буфера памяти) в окошке «Вариант ответа», после чего нажимается клавиша «ENTER», окошко очищается, введенный вопрос перемещается в окно «Правильные варианты ответов…» программа ожидает ввода следующего ответа:

Рис. 8. Ожидание следующего ответа

После того, как все ответы введены, надо пометить «галочкой» вариант правильного ответа, программа активизирует кнопку «Включить вопрос в тест»

Рис. 9 Включение вопроса (с ответами) в тест

2.2.3. Сохранение теста

Если вы захотите сохранить проект (тест) перед введением вопросов и ответов, то программа откажется это сделать, выдав сообщение «Введите хотя бы один вопрос». Поэтому первый раз сохранить проект следует после введения первого вопроса с ответами на него (то есть после нажатия кнопки «Включить вопрос в тест». Для этого в пункте меню «ФАЙЛ» выбирается «Сохранить». Вам будет предложено выбрать место для сохранения; вы выбираете предварительно созданную папку с именем теста, открываете его и сохраняете проект. Желательно сохранять тест после введения каждого вопроса, это предохранит вас от непредвиденной потери вашей работы вследствие каких-либо причин.

После сохранения (латинскимибуквами!) вводите следующий вопрос, ответы на него (не забывайте давать оценку в баллах за правильный ответ!), нажимайте кнопку включения вопроса в тест, сохраняйте проект, и… вводите следующий вопрос.

2.2.4. Сохранение теста в формате HTML

Наконец-то все вопросы введены, готовый тест сохранен и пора переходить к заключительному этапу нашей работы – сохранению проекта в формате HTML.

Тест будут сохранен в виде небольшого WEB-сайта (точнее – WEB-страницы с обслуживающими элементами и компонентами.

Для сохранения нашего проекта в формате HTML выбираем в меню «ФАЙЛ» пункт «Сохранитьв формате HTML» – и наш тест создан. Можно со споойной совестью выъодить из «Тестмейкера».

Ну и что же мы имеем в итоге?

Допустим, наша папка с проектом называется TEST_R.

Открыв ее, мы обнаруживаем там вот такое содержание:

bg.gif; no.gif; pixel.gif; spider.jpg; TEST_R.chm; TEST_R.css; TEST_R.htm; TEST_R.js; TEST_R.tst; TEST_R_ans.ts; TEST_R_quest.ts; yes.gif.

Что это такое? А вот что:

bg.gif – файл рисунка, служащего фоном WEB-страницы;

no.gif– файл рисунка, маркирующего неправильный ответ;

pixel.gif – вспомогательный файл («распорка» разметочной таблицы);

spider.jpg– файл логотипа;

TEST_R.css– файл каскадных таблиц стилей (стилевой файл CSS);

TEST_R.htm– собственно HTML-страница;

TEST_R.js– скриптовый файл Java Script;

TEST_R.tst, TEST_R_ans.tsиTEST_R_quest.ts– файлы «тестмейкера». Если вы не планируете изменять в дальнейшем ваш тест, эти файлы можно спокойно удалить.

yes.gif– файл рисунка, маркирующего правильный ответ;

Если вы желаете в будущем применять ваш тест в работе со школьниками или другими категориями обучаемых, то учтите, что обучаемые тоже кое-что понимают в компьютерных объектах, и открыв в «блокноте», например, файл с расширением *.js (скриптовый файл) без труда найдут там номера правильных ответов на каждый вопрос. Можно, конечно, поставить скриптовую защиту на код вашего проекта, но самый лучший выход – это создание из вашего проекта CHM-файла (файла «помощи»). Тогда все премудрости и хитрости вашего проекта будут надежно защищены от постороннего несанкционированного вторжения. В этом случае вы будете иметь один-единственный файл, например (по имени вашего проекта) TEST_R.chm.

Удачной вам работы с «Тестмейкером»!

© TGPI Salekhard Filial CIOT 2005